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PTC 
Shaping Innovation 

 
Training Program Concepts 

Outline/Checklist  
Design & Technology in Schools Program 

 
 

 
 
• o Sketches l     o Generating 

• o Modifying  
• o Constraints 

• o Transform and o Duplicate functions 
• o Extrude Profile  l          o Taper 

• o Thin 
• o Round Edges  l          o Constants & o Variable radius 
• o Chamfer Edges l          o Equal and o unequal setback 
• o Shell  
• o Work-planes l         o Selecting 

• o Generating 
• o Offset 
• o Angled 

• o Redefining Features 
• o Revolve Profile 
• o Sweep Profile along a Profile 
• o Holes 
• o Draft Faces 
• o Lofting 
• o Sweep Profile along a Helix 
• o Feature Modification l         o Deform Face 

• o Pattern 
• o Mirror 
• o Scale 

• o Assembly l         o Working with Components 
• o Transform 
• o Duplicate 
• o Use 

• o Drawings l         o Generate drawing 
• o Add views 
• o Section Views 
• o Dimensioning 
• o Adding Text 

• o Album  l         o Rendering 
• o Adding Textures 
• o Adding background images 
• o Importing backgrounds and textures 
• o Studio functions  
• o Printing and o print resolution 

• o Saving files - the importance of saving associated files 
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 Pro/DESKTOP is a 3d/2d Modelling Environment.  
 
It enhances a different way of thinking about Graphics problem, but still the student 
must analyse the drawing problem in order to efficiently & effectively solve the 
problem.  
 
 
Pro/DESKTOP works on: 

1. Faces being selected 
2. Workplanes either New or already in use 
3. New Sketch 
 
A Workplane may be used for many Sketches, BUT a Sketch can be used for only 
one operation. 

 
These notes have been used in a class situation and corrected as needed, BUT there 
may still be small errors. E-mail nevobrien@uq.net.au for mistakes. 
 
 
There is a copy of these notes on the INTAD web site under Pro/DESKTOP 
http://www.intad.asn.au 
 
Many of the competencies are covered by these brief notes.  
 
The notes are “cooking recipes” & seem to be most suitable for middle secondary 
students. 
 
INTAD is looking for other “lessons” to increase our knowledge store. We need to 
share. 
 
Several web sites to visit: 
http://www.ptc.com 
http://www.prodesktop.net 
http://www.tep.org.uk 
 
If you find any other sites, inform INTAD. 
 
Pro/DESKTOP has tutorials in its help system plus a Getting Stared Guide (68 pages) 
& a User Guide (362 pages) usually at:  
 
C:\Program Files\PTC\ProDESKTOP 2000i2\Program\Help 
 
******************************************************************* 
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Pro/DESKTOP 2000i2 Toolbars 
 
Standard Toolbar 
 

   
 

 
 
Features Toolbar 
  
 
 
 

   
 
 
 
 
Views Toolbar 
 
 
 

 
 
 
 
 
 
 
Constraints Toolbar 
 
 
 

  
 

Update 
Design 

Autoscale 

Zoom In

Half 
Scale 

Free Rotate 

Tumble 

Extrude 
Profile 

Project 

P
Revolve 
Profile 

Sweep Profile
Along Profile 

Hole 

Round 
Edges 

Chamfer 
Edges 

Shell Draft Faces 

Use  
Components 

Wire 
Frame  

Shaded 

Transparent 

Enhanced 

Trimetric 

Isometric 

Plan 

Front 

Right 

View Onto 
Workplane 

View Onto 
Face 

Autoscale 
Selection 

Parallel 

Perpendicular 

Colinear

Tangent 

Concentric 

Equal  
Length 

Equal  
Radius 

Toggle Fix 
Lines 

Constraints 
Inspector 
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Design Toolbar 
 

                             

Browser Pane 
 

 
 
 

 

Select Lines 

Select 
Constraints 

Select 
Workplanes 

Select Edges 

Select Faces 
Select 
Features 

Select Parts 

Straight 

Circle 

Rectangle 

Ellipse 

Arc/Fillet 

Spline 

Delete Line 
Segment Sketch 

Dimension 

Workplane 

Active Sketch
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Menus 
File  

  
Edit  

 
View  

 
Help 

 

Select  

 
Line 

 
Constraint 

  
Feature  

 
 

Assembly 

  
Workplane 

 
Tools 

 
Windows 
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Pro/DESKTOP 2000i2  Keyboard Commands 
 

 
Sketch Commands 

Menu Command Button Hot Keys 
Line Straight  S 

 Circle  C 
 Rectangle  R 
 Ellipse  I 
 Arc  T 

 Spline  B 
 Delete Segment 

 
D 

 Toggle Construction  Crtl + G 
 Toggle Sketch Filled  Ctrl + Shift + F 
 Toggle Sketch Rigid  Ctrl + Shift + R 
Constraint Dimension  Z 
 Parallel 

 
 

 Perpendicular 
 

 

 Collinear 
 

 

 Tangent 
 

 

 Concentric   

 Equal Length 
 

 

 Equal Radius 
 

 

 Toggle Fixed  Ctrl + F 
 Toggle Reference  Ctrl + R 
 Inspector 

 
 

Select Lines 
 

L 

 Constraints  N 

Design Commands 
Feature Extrude Profile   

 Project Profile   
 Revolve Profile 

 
 

 Sweep > Sketch Path 
 

 

 Insert Holes 
 

 

 Round Edges 
 

 

 Chamfer Edges   

 Shell Solids   
 Draft Faces 

 
 

 Use Component   
 Update Design  F5 
 Update & Propagate  Ctrl + F5 
Tools Components Browser  Shift + C 
 Features Browser  Shift + E 
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 Workplanes Browser  Shift + K 
Workplane New Workplane  Ctrl + L 
 New Sketch  Ctrl + K 
 Hide Other Sketches  Ctrl + H 
Select Workplanes 

 
W 

 Edges 
 

E 

 Faces 
 

F 

 Features  A 
 Parts  P 
 Add Connected Lines  Ctrl + E 
 Synchronize Browser  Shift + B 
Drawing Commands 
Select Annotations 

 
A 

 Features  F 

 Views 
 

V 

 Add Connected Lines  Ctrl + E 
 Synchronize Browser  Shift + B 
    
Center Line Common Plane   
 Common Axis   
 Mid-Plane 

 
 

 Pitch Circle   
 Center Points   
 Phantom Intersection 

 
 

Dimension Linear 
 

 

 Angular 
 

 

 Diametric   
 Radial   

 Note   

 Geometric Tolerance 
 

 

 Datum Feature 
 

 

 Design Variables 
 

 

 Surface Finish   
 Part Reference Balloon 

 
 

 Insert Callout Note  Insert 
 Move Callout L/R/Up/Down  Arrows 
 Start New Line  Enter 
 Shoulder Right  Ctrl + Right Arrow 
 Shoulder Left  Ctrl + Left Arrow 
Drawing Update Views 

 
F5 

 New Sketch  Ctrl + K 
 Hide Other Sketches  Ctrl + H 
Table Cycle Row Up  Shift + Up Arrow 
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 Cycle Row Down  Shift + Down 
Arrow 

 Cycle Column Left  Shift + Left Arrow 
 Cycle Column Right  Shift + Right 

Arrow 
General Commands 
File New 

 
Ctrl + N 

 Open  Ctrl + O 
 Save  Ctrl + S 
 Print  Ctrl + P 
Edit Undo  Ctrl + Z 
 Cut  Ctrl + X 
 Copy  Ctrl + C 
 Paste 

 
Ctrl + V 

 Delete  Delete 
 Select All  Ctrl + A 
 Duplicate  Ctrl + D 
 Properties  Alt + Enter 
 Pick Up Properties  Ctrl + Shift + C 
 Apply Properties  Ctrl + Shift + V 
    
View Auto Scale  Shift + A 
 Autoscale Selection  Shift + S 
 Half Scale  Shift + H 
 Zoom In 

 
Shift + Z 

 Manipulate 
 

Space 

 Wire Frame  F9 
 Shaded  F10 
 Transparent  F11 
 Enhanced 

 
F12 

    
View>Go To Isometric  Shift + I, Home 
 Trimetric  Shift + T, End 
 Plan  Shift + P 
 Front Elevation  Shift + N 
 Right Elevation  Shift + R 
 Onto Face  Shift + F 
 Onto Workplane  Shift + W 

 Previous  Alt + Left Arrow 
 Next  Alt + Right Arrow 
View>Rotate Spin Left/Right  Left/Right Arrow 
 Tilt Up/Down  Up/Down Arrow 
 Turn Counter Clockwise  Page Up 
 Turn Clockwise  Page Down 
 Tumble 

 
Shift + U 
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Tools Variables  Alt + 1 
 Design Rules  Alt + 2 
 Configurations  Alt + 3 
Tools>Macro Record New Marco   
 Stop Recording   
 Marcos  Alt + F8 

 Resume Marco I> Alt + F9 
 Visual Basic Editor  Alt + F11 

Special Control Features 
Keystroke + Selection = Action 
Shift Modifying end point of a line Extend or trim a line 
Shift Straight line being created Parallel to workplane axis 
Double Click Object not on active plane Activities its sketch 
Double Click Selected object Open properties dialog box 
Ctrl + Double 
Click 

Object Select feature & sync browser 

Esc New Object Open selection command 
Shift Section or projected view View will align to its principal view 
Shift Add note Note is placed without leader 
Shift Radial dimension Diameter dimension is placed 
Shift Angular dimension Major angle is dimensioned 
Mouse Items 
 
Manipulate 
Scene 

 

  Spacebar (On/Off) 

- Hold down Left mouse 
button to Rotate in 3 
dimensions 

- Shift + Hold down Left 
mouse button to drag/adjust 
position on screen 

- Shift + Ctrl + Hold down 
Left mouse button to Rotate 
in one plane 

Zoom in/out Scroll Wheel on mouse Rotate Scroll Wheel to enlarge or 
reduce scale 
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From Help File 
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Introduction: 

1. Left Mouse Click (LMC) the New icon   > select Design > OK 

 

2. Go full screen to obtain a larger working area. 

3. Same operation for New Drawing or New Album 

 

 

Notes: 

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________

___________________________________________________________________________________ 
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Workplanes:  
 

1. It is essential that students be introduced to the notion of Workplanes & New 
Sketches at a very early stage, if not the first stage. 

2. Use  to show the three Workplanes that are set-up in Pro/DESKTOP. 

 
3. Only the Base Workplane has a New Sketch already on it. Left Mouse Click 

(LMC) any Workplane > it goes orange/red > Right Mouse Click  (RMC) and 
choose New Sketch from menu OR goto Workplane > New Sketch  

 

 
 

Lateral Workplane 
Gives Right Side 
View 

Frontal Workplane 
Gives Left Side View 

Base Workplane has a New Sketch 
called Initial by default 
Gives Top View 

LMC turns Workplane 
Orange/Red 

RMC Workplane & 
choose New Sketch 
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4. Rename the New Sketch to a more meaningful name than Sketch 1 as this will 
allow the identification in a complex drawing & is good practice.    

 > OK 
5.  

 

 
 
 
 
 
Notes: 

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 

 
 

Rename New Sketch 

Base Workplane has Initial as default Sketch name 

Note the Sketch is shown as the changed name. 
The Sketch name is in Bold when it is the selected Sketch 

A New Sketch can be added by RMC the Workplane name in 
the Browser area & selecting New Sketch from short menu. 
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Save Files for Moving from Present location: 
 

1. Use File . This will allow the Saving of the file 
& associated files to a new location such as a floppy disk instead of the 
computer’s C:/ 

 
2. Specify a Filename, Folder location and Drive letter as needed > OK 

 
 

3. For Example: all files to do with an Assembly design would be saved to the 
new location. Pro/DESKTOP uses an internal referencing system to keep track 
of the associated files. This allows Pro/DESKTOP files to be kept to a small 
file size as the Assembly file has the required location/filename etc as part of 
its file information. 

 
 

4. Similar for e-mailing the files. 
 
 
Notes: 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
 
___________________________________________________________________________________ 
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Redefining Features: 
1. Features can be redefined by selecting the Features in the Select Browser 

drop-down list  
 
 

2. Right Mouse Click (RMC) the Feature that requires changing > select 

Redefine from menu  
 
 

3. Change as needed > OK 

4. Drawing might require an Update   after redefine is used. 
 
 
 
Notes: 

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 
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Thin: 

1. For some reason the following profile was drawn using the Spline tool  

2.  
 
 

3. An Extrude Profile >  > OK  
 
 

4. Gives this  
 
 

5. There are many irregular profiles that can be formed by using the Spline & 

Thin command.  
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Transform & Shell: 
1. Draw a Rectangle & a Square (hold down Shift to obtain Square) 

 

2. Right Mouse Click (RMC) Square > choose Transform >  
> OK 

3. Rotated Square  
4. Extrude Profile > Below Workplane > OK 

5. Shell  > select top face >  > OK 

6. Shelled solid  
7. Shelling to make a pipe or similar: select Faces as required & Shell as 5 & 6 above. 
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Chamfer Edges: 

1.           
 

2. Angle Setback  > OK  

 
 

Round Edges  
 

1.  > OK 

Equal 
Setback 

Unequal 
Setback 
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2. How to make an end into a semi-circle using Round Edges 

 > OK 
 
Semi-Circle using Cutting Plane 
 

1.  > OK 
 
Semi-Circle using Normal Viewpoint  
 

1.   
 

2  Finished Object 

Select Edges to be curved into Semi-circle. 
 
Use Round Edges icon and input the Radius 
 
OK 

Notice that the Cutting Plane must be a 
closed figure 

Plan for the use of Circle 

 
Remove any stray lines/curves 
 

Ext
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Round Edges Variable Radius: 
 

1.    > OK 
 
 

2.   
 
3. If there is a need to have another edge with the same edge treatment, use the 
following: 
 
 

Select the Rounded Face   . Note: The normal Copy 

icon becomes active  .       Click Copy. 
 

Select the required Edge & use Paste icon   .  

 The Features browser shows that the copy has taken place  as well 

as the Design.    

LMC & drag the Yellow/Green 
indicators to apply various Radii 
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RMC the Round 1_copy & select Redefine.   
 

  
 

 Final Product.  
 
Only one at a time can be completed in this manner. 
 
 
Notes: 
 

 

 

 

 

 

LMC the Reverse 
button 
 
Then OK 
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“Joining” two pieces of Steel/Timber: 
 

 
 

 
 

 
 

  
 

First Piece:  
Assembly > Add Component > choose Component > OK 
Assembly > Fix Components 

Second Piece: 
Assembly > Add Component > choose Component > OK 

Select two faces   
 
 Right Mouse Click (RMC) > choose Mate  
 
Pieces come together as such 

These two selected Faces need to be a 90o to each 
other & 50 mm from each other. 
 

Use Select Parts  to move them in relation to 
each other as the Offset command does some ‘odd’ 
things: seems to go the wrong way  
 
RMC  > Offset 

Set Offset to 50 
 
Check Align button is selected 
 
Use Preview to ensure that the ‘odd’ thing 
mentioned above does not happen before you 
click OK 
 
If the Preview is not correct, Cancel & use the 

Select Parts   to readjust the position 

Files for this activity are at 
www.intad.asn.au follow to 
Pro/DESKTOP page 
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The non-Fixed part will be rotated to 
Align itself  & will be Offset the distance 
away as specified 

Select two required Faces  
 
Set Offset to 60 
 
Check Align button is selected 
 
Use Preview to ensure that the ‘odd’ thing 
mentioned above does not happen before you 
click OK 
 
If the Preview is not correct, Cancel & use 

the Select Parts   to readjust the position 

Final Product 

Shows Offset used 
for both sets of Faces. 
Needed to use a –15 
Offset for this 
exercise 
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Angular “Joining” of Steel/Timber:  
 

1. Draw the parts as required. 
2. New Design 
3. Assembly > Add Component > choose part > OK 
4. Assembly  > Fix Component 
5. Assembly > Add Component > choose part > OK 

6. Select  the top face & the bottom face of the parts & Assembly > Mate 

7. Looks like this    

8. Select  a long Edge of the top part & a long Edge of the bottom part. Right 

Mouse Click (RMC) or Assembly > Orient   

9.   > OK 

10. Select  two short vertical Edges as shown > RMC or Assembly > Centre 

Axis   

11. Final Product   showing Angular 
Joining for Steel/Timber. 

Select these Edges  
 

RMC > Orient

Type in an Angle 

Use Preview to get an idea if the Angle is going to be correct 

Select two short vertical Edges as required 

Use Centre Axis 
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Butt  

 

  

  

 

Hinge Action  

  

 

Mitre   

  

 

Select & RMC & Align Top Faces 
 
Select & RMC & Align these Faces 
 
Select & RMC & Mate these Faces 

Select & RMC & Align Top Faces 
 
Select & RMC & Mate these Faces 
 
Select & RMC & Offset > 15 > Align > OK 
these Faces 

Select & RMC & Align these end Faces 

Select & RMC & Align Top Faces 
 
Select & RMC & Centre Axis on these Edges 

 
Select & RMC & Centre Axis these Edges 
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Holes Centred & Rotation 

 

                                                     

  

 

 

 

 

 A non-circular Hole can be used for rotation 

by using an Edge of the Hole to Centre Axis > OK 

Select & RMC & Mate this top Face & this 
underside Face 
 
Select & RMC & Centre Axis of two Holes 

Select Faces & RMC & 
use Offset > 25 > Align > 
OK these Faces 
 
Select & RMC & Centre 
Axis of two Holes 

Use for surfaces in contact with each other 

Use for surfaces which are not in 
contact with each other e.g. a set of 
drawers opening around a central post. 
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Holes/Threads:  
 

1. Draw a circle in the required place > use   
 

2.  > OK 
 

3. The Hole can be previewed   
 
4. Because each hole is at a different depth, a New Sketch needs to be added to the Base 
Workplane. 

5.  > OK 
 

Hole 1 

Hole 2 Hole 3 
Hole 4 
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6.  > OK 
 
 

thomaspope  
Member since Jan-7-02 
 Oct-29-02, 09:33 AM (EST) 3. "Creating a male thread"  
   Oh! I understand now. You want the lines to look thin and not dashed. You have to change the 

line style. First, select the view(s)  you want to change. Then select Drawing and Set Line 
Properties... and change hidden to a thin line instead of dashed. 

Please note that the lines are hidden for the thread detail and changing the line properties 
changes hidden lines for the entire view, not just for the threads. 

  

By using this Check Box , an 
Internal (Nut) Threaded Hole can 
be shown.  
 
But the External (Screw/Bolt) 
Thread cannot be shown as yet. 
See below. 

 

Choose Tapped, Full Thread 
 
Thread size & drilling size 

 

In reply to a query of mine on Topic 499, prodesktop.net, 
discussion forum, on male threads. Edited message. 

Two Design files 
Assemblied- eg 
for M36 thread, 
drill size 32. 
Two cylinders 
of correct sizes 
& Chamfer 2 on 
M36, Assemble 
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Sweep Profile along Sketch Path:  

1. Draw a Circle on the Base Workplane > RMC Initial rename Profile >  

> select the Frontal Workplane   RMC > choose New Sketch 
> rename Path > OK. Note: Path & Profile MUST be at 90o except as here. 

2. Draw a sweep path  
3. Feature > Sweep Profile > Along Sketch Path > 

 > OK 

4. Finished Product .  
5. Select both end faces & Shell @ wall thickness of 2 > OK 

 
6. Sometimes a “pipe” can be done by Sweep along a Sketch Path 

  

Sweep Path 

Sweep Path 

Start with concentric 
Circles as Profile 

- Use the same Workplanes as before, but 

draw the Path using the Spline  tool 
 
- The Path & Profile will NOT be at 90o 

 

- Generate the shape    
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Helixes      

1. New  > New Design, OK 

2. Draw a rectangle  on the Workplane 
3. Workplane > New Sketch 
4. Draw, holding down SHIFT key, a line. 
5. Feature > Sweep Profile > Along Helix 
6. Click Extrude Profile, use Yellow Button or type in a Pitch measurement,  OK 

 
 

 

 

 
 

Note: The Axis line can be at an angle 
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Glass   
 

1.   
 
2. View Isometric 

Use frontal/lateral workplane, put a 
New Sketch on that workplane, then 
draw the Section of the Glass 

Place another New Sketch on the 
same Workplane to use as the 
rotational Axis 
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3. Feature > Revolve Profile  
 

4.  > OK 
 

5. Choose the Top Lips  and apply a 2 mm Round edge to them 

 >OK 
 
6. Save as Glass.  
 
7. Goto New > Album > OK 
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Table      
 

BODY 
1. New  > New Design, OK 

2. Draw a rectangle  on the Workplane 

3. Draw a smaller rectangle inside the original. Dimension  the inside 
rectangle, note these dimensions for the INSERT piece. 

4. Click Extrude Profile  BELOW Workplane. Click/Hold/Drag Yellow 
Button down, OK 

5. Select the Left hand face of this extruded part , goto Workpalne > New 
Workplane, �Plane of Object, OK, goto Workplane > New Sketch, OK  

6. Draw a rectangle on this sketch so that it lies inside top/right/left edges and 
outside bottom edge and click Extrude Profile, click radio buttons Below 
Workplane and Subtract Material, fully Extrude it until it is clear of back face, 
(use Yellow Button or type in a measurement), OK 

 
7. Select Right Hand face. Repeat 5 & 6 above. 
8. Save your work as Table Body 

 

Insert Piece 
1. New  > New Design, OK 
2. Draw a rectangle, use the Dimensions from above to constrain the Insert size. 

3. Click Autoscale  
4. Extrude Profile, Below Workplane, OK 
5. Save your Work as Table Insert. 
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ASSEMBLY 
1. New  > New Design, OK 
2. Assembly > Add Component, click Table Body, Open 
3. Assembly > Fix Components. 
4. Assembly > Add Component, click Table Insert, Open 

5. Select Faces  - top of Body and hold down the SHIFT key + left click top 
of Insert. Both should go reddish colour. 

6. Assembly > Align 

7. Select Faces - an edge of Insert and SHIFT + left click corresponding part 
of Body. Both should go reddish colour 

8. Assembly > Mate.  
9. Repeat 7 & 8 for other edge at 90o. 
10. Save as Table Assembly. 

 

ALBUM 
1. New  > Album, OK 

2. Image > New Image, click Table Assembly, OK, Update  

3. Drop down the Images box  and choose Materials 
4. Click + on Non-metal. Left click and drag Wood, Varnished to the Image until 

the wire frame of the Body is showing. Let left mouse button go. Update. 
5. Left click and drag Glass to the Image until the wire frame of the Insert is 

showing. Let left mouse button go. Update. 
6. Image > Image Properties, Studio > Lighting. Choose Room Lighting, OK. 

Update. 
7. Save as Table Album. 

 

Extension 
 

1. Design an Insert as above but ensure the Checkerboard design in the Album 
area fits it on an 8 X 8 pattern. Save. 

2. Design an indoor Games Table along the same idea as above. Save. 
3. Assemble the two components. 
4. Save. 
5. Goto Album and import the above assembly. 
6. Drag & drop the material for the Games Table part. 

7. Click Select Faces icon  before dragging & dropping the Checkerboard 
pattern onto the Insert. 

8. Save. 
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Barbeque      

BODY 
1. New  > New Design, OK 

2. Draw a rectangle  on the Workplane 

3. Click Extrude Profile  BELOW Workplane. Click/Hold/Drag Yellow 
Button down, OK 

4. Workplane > New Sketch 
5. Draw a small Rectangle on the back edge for Fume Funnel. Extrude up.  OK 

6. Select the top face of this extruded part , goto Workpalne > New 
Workplane, �Plane of Object, OK, goto Workplane > New Sketch, OK  

7. Draw a smaller rectangle on this sketch and click Extrude Profile, click radio 
buttons Below Workplane and Subtract Material, Extrude, (use Yellow Button 

or type in a measurement) OK  
7. Select Left Hand face, Workplane > New Workplane, �Plane of Object, OK. 

Workplane > New Sketch, OK 
8. Place a three rectangles on this face. One for the BBQ plate to cover and two 

smaller ones for storage. Dimension  the TOP edge of the large rectangle, 
note this dimension + the depth of the Extrusion for BBQ Plate size. Goto 

Extrude Profile  and extrude back to nearest point of Fume Funnel, OK. 
9. Save your work as BBQ Body 

 

PLATE 
1. New  > New Design, OK 
2. Draw a rectangle, use the Dimensions from above to constrain the Plate size. 

3. Click Autoscale  
4. Extrude Profile, Below Workplane, OK 
5. Save your Work as BBQ plate 
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ASSEMBLY 
1. New  > New Design, OK 
2. Assembly > Add Component, click BBQ Body, Open 
3. Assembly > Fix Component 
4. Assembly > Add Component, click BBQ Plate, Open 

5. Select Faces  - top of Body and hold down the SHIFT key + left click top 
of Plate. Both should go reddish colour. 

6. Assembly > Align 

7. Select Faces - an edge of Plate and SHIFT + left click corresponding part 
of BBQ Body 

8. Assembly > Mate. 
9. Repeat 5 & 6 for front edge of Plate & BBQ Body. 
10. Save as BQQ Assembly. 

 

ALBUM 
1. New  > Album, OK 

2. Image > New Image, click BBQ Assembly, OK, Update  

3. Drop down the Images box  and choose Materials 
4. Click + on Non-metals. Left click and drag Bricks to the Image until the wire 

frame of the Body is showing. Let left mouse button go. Update. 
5. Click + on Metals. Left click and drag Cast Iron to the Image until the wire 

frame of the Plate is showing. Let left mouse button go. Update. 
6. Image > Image Properties, Studio > Lighting. Choose Room Lighting, OK. 

Update. 
7. Save as BBQ Album. 

 

Extension (diy)  
 

1. Design a Gas Bottle for the BBQ. 
2. Remove one of the storage parts from the front of the Body. 
3. Place a rectangular compartment in the right hand end. 
4. The Gas Bottle would need a round indent in the floor of this compartment for 

its base. 
5. Save. 
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Tap Handle   
 

1. Using the Base workplane, draw a circle @  and dimension it at Diameter 
80. 

2. Autoscale  to see a larger view. 

3. Extrude Profile - Above Workplane, Distance 50, Taper Angle 12, OK.  

 
4. Autoscale to see a smaller view. 

5. Select top face . Goto Feature > Modify Solids > Deform Face > Height 15 

 OK. 

6. Select Workplanes . Left Mouse Click (LMC) Frontal (goes Red). Right Mouse 
Click (RMC) Workplane. Select New Sketch > rename Handles Front. OK. 

7. View Onto Workplane .  
8. Draw a Rectangle of size 8 wide & full height. Constrain it by Dimensioning. Hint: 

Draw a control Line down the middle & Toggle Construction it to be a hidden line. 

                                         

9. Goto View Isometric . 

10. Extrude Profile .  OK. 

Control Line  
 
Toggle Construction 

After using Dimension, use 

Select Lines  and 
move Control Line back to 
central alignment. 
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11. Using Lateral Workplane, REPEAT 6 to 10 BUT rename New Sketch > Handles 
Lateral 

12. View Isometric  Looks like this. 

13. Select Edge  & Round   to  Radius 10.  OK 

 
14. Round other edges as you see fit. 
15. Move around so that the bottom face is visible. 
16. Select the Bottom Face > RMC > select New Sketch > rename Bottom Recess OK 
17. Draw a concentric Circle of Diameter 70. Extrude Profile > to a depth of 10 > 

Subtract Material >   OK 
18. Select bottom Face of 17 above > RMC > select New Sketch > rename Tap Insert OK 
19. Draw a concentric Circle Diameter 8. Draw & constrain 2 lines at 3 either side of 

centre . Remove parts of circle & lines not needed. 

20. Extrude Profile >  OK 
 
 

21. Save as Tap Handle. 

Select one Edge 
Shift LMC other 
edges 
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Drawing 

 
 

2. Use Tools > New Drawing   > OK 
 
 

3. Select  and the modelling containers show as broken lines > Left Mouse 

Click (LMC) the right side view > container goes red > press 
Delete key  

 
 

This one will give third 
angle orthographic with 
isometric view 

Choose Existing Design 

Select the open file  
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4. LMC the left side view container > Right Mouse Click (RMC) > select Add 

Section View  >  > OK. There is 
some problem with where the views go in Pro/DESKTOP. The views may 
need to be moved using drag & drop with LMK. 

 

5. Import the dimensions by RMC >  
 

6. Use Shift+Z to zoom in on dimensions to change to zero decimal places & 
Shift+A to Autoscale back. 

 

7. Use  to drag a labelling box (hold down the Shift key to remove leader 
when dragging), double LMC box & Capitals for subtitles & name block 
entries. 

 
8. Save as Tap Handle 
 

Print 
 
1. File > Print Setup > change to Landscape > OK 
2. File > Print Preview to check > Close 
3. File > Print > (check printer type, change through Setup) > OK 
4. LMC the Print True Scale check box (be careful as this will print True Scale & 

leaves off the Border) 
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Tap Lever  
 

1. Follow the Tap Handle sheet for everything except the Handle part. 

2. Select Workplanes > Left Mouse Click (LMC) either Frontal or Lateral Workplanes  

turns red > Right Mouse Click (RMC) > select New Sketch rename to Lever > OK 

3. View Onto Workplane  

4. Draw a rectangular profile using the Line tool. Ensure that the lines are parallel to 

each other & the angle is 60o. Hint: use a vertical control line reset to toggle 

construction to constrain the angle.  

5. View Isometric. 

6. Extrude Profile >  OK 

7. Select top face of Lever. RMC > New Sketch > OK 

8. View Onto Workplane. 

9. Goto Line > Add Text Outline > type <C  H> to give instruction on which way to 

turn the Lever for Hot or Cold water. The text size/font types will need some 

adjustment to fit onto the Lever width. 

10. View Isometric 

11. Extrude Profile the lettering to 1, Above Workplane, Add Material, OK 

12. Round off all the edges as needed. 

13. Save as Tap Lever. 

Vertical control line , 
toggle construction 



45 

For use with PTC’s Pro/DESKTOP 
Copyright remains with INTAD unless shown 

Free use by places of education 

Lofting Through Profiles  
 

1. Use the Base Workplane (it has a sketch on it already called Initial) 

2. Draw a Rectangle & Dimension it at 200 X 150.  
3. Workplane > New Workplane > Offset 70 > OK 

 
4. The new Workplane is red > Right Mouse Click (RMC) > select New Sketch 

 > OK Note: its name is Sketch 1 
5. Draw a Rectangle & Dimension it at 300 X 250 
6. REPEAT steps 3 & 4 except make the Offset 50. New Sketch name is Sketch 

2 

7. Draw a Circle & Dimension it to Diameter 150. There may be a need to . 

8. Looks like  
9. Feature > Loft Through Profiles > Left Mouse Click (LMC) each item & it 

appears in the Loft Profiles dialog box in the order of selection. This order can 

be adjusted   
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10. To move the point from which the Profile starts the Profile must be LMC 

inside the above dialog box. Pickup yellow Dot & LM drag to where you want 

it to be.  > OK 
 

11. Looks like this.  
 

12. Save as Bottle 1 
 

13. All Sketches can be moved & the drawing Updated .  
 

14. The Loft can be changed by RMC the Loft 1 in the Features Browser 
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15. Move the Yellow Dot to here  
 

16. This will require OK & produces a twist in the Object 

 
 

17. Save as Bottle Twist 
 
Another Twist that could be useful: 
 
To “move” from a horizontal orientation to a “vertical” orientation: 
 

 Use two parallel, offset Workplanes, rotate the 
Rectangular Face 90o then Loft so that the Twist is as shown. 

This example uses the Lateral 
Workplane as a starting 
plane. 

Offset Workplane with a New 
Sketch & rotated 90o 
Rectangle 

 

This linking will produce 
required Twist 

 Assembly of several to form decorative finish 
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Bottle with Handle  
1. Use the frontal or lateral workplane. RMC > New Sketch > rename Profile 

2. Draw & Revolve a similar profile  Note: that profile is a Section 
through centre of Bottle. 

3. Add New Sketch to same Workplane > rename Axis 
4. Draw a Line to be used as the Axis of Rotation 
5. View Isometric 

6. Feature > Revolve Profile >  > OK 
7.  Save as Container Round 

8. Select Workplanes , LMC Lateral Workplane > RMC Workplane > New 
Sketch > rename Side Removal > OK  

9. View Onto Workplane  

This profile. Not the 
handle profile 

Handle Profile (later) 
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10. Draw the Rectangles shown.  
11. View Isometric 

12. Extrude Profile  > OK 

13. Looks like this  

14. Select  one of the Cut-off Faces > RMC > New Sketch > rename Handle > 
OK 

15. View Onto Workplane  
16. Draw two Circles & Dimension to 30. Draw Tangent Lines to each Circle. 

Check tangency by LMC an item & Shift + LMC the other so both are Red > 

 

17. Use the Spline Tool   to make the Straight Lines form a curve. Select both 

arcs as above in 16, then select Equal Radius . Clean up all unneeded parts 

of the circles with the Delete Line Segment  
18. View Isometric 



50 

For use with PTC’s Pro/DESKTOP 
Copyright remains with INTAD unless shown 

Free use by places of education 

19. Extrude Profile  > OK 

20. Select Top Face > Shell >  > OK 

21. Finished Product  
22. Save 

 
 
Notes: 
 

 

 

 

 

 

 

Note the “Hollow” 
inside 

Handle goes all 
the way through. 
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Machined Part  
 

1. Select   the Lateral Workplane > Right Mouse Click > select New Sketch. 

2. Draw some type of shape on the Workplane  

3. Extrude Profile > to some width  > OK 
4. Select Top Face & RMC > select New Sketch > rename Profile > OK 

5. View Onto Workplane  
6. Draw a Line & Dimension it 50 away from bottom face > RMC > Toggle Construction 

 
7. View Isometric 

8. Workplane > New Workplane >  > OK 
9. RMC Workplane > select New Sketch > rename Profile > OK 

10. View Onto Workplane  Use  to see lines. 

11. Draw a profile   

Use a Rectangle & a circle 
Check for Tangency Remove 
any unneeded lines/curves 
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12. View Isometric 

13. Project Profile >  > OK 

14. Looks like this  
15. Select Profile Face > RMC >select New Sketch  > rename Hole > OK 

16. Draw a Circle on the face  

17. Extrude Profile >  > OK 
18. Save as Machined Part 



53 

For use with PTC’s Pro/DESKTOP 
Copyright remains with INTAD unless shown 

Free use by places of education 

Mirror & Revolve Profile of Wheel:  

1. Draw two control lines & toggle construction   
 

2. Line > Mirror >  select the lines Shift + LMC 
> select the Axes > OK 

 

3. Profile is complete  
 

4. Line > Toggle Sketch Filled ensures that sketch is closed   

Control Lines  
Toggle Construction 

Profile of Wheel 
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5. View Isometric 

 
6. Workplane > New Sketch > rename Axis > OK 

 
7. Draw a Line through control line 

 

8.                      
 

9. Feature >Revolve > Profile >  > OK 
 

10. A partial “section” can be done by making the angle 270o 

 
 

11. Select face as above  
 

12. View Onto Workplane  
 

13. Draw a Circle > RMC > Duplicate >  > OK 
 

14. View Isometric 
 

Axis line 

Choose this face > 
RMC > New Sketch > 
rename Slots 
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15. Extrude Profile >  > OK 
 

16.  
 

17. Round Edges  > select all edges that have same radius > 10 > OK  
 

18. Final Product   
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Gear Simple:  
 

1. Draw a Circle on the Base Workplane & dimension to 60 diameter  

2. Use Autoscale  to see a reasonable size Design 

3. View onto Workplane  to view a single plane view of the object 

4.  Draw the Gear Shape   

5. Select Both Lines  RMC > Duplicate 

6.                                        > OK 

7. Looks like this   

8. View Isometric   

Draw a vertical line 

Draw an angled line past 
the edge of the Circle to 
avoid tangent to Circle.  

Trim to Circle  
 

Total Angle 360 

Circular 

Number 12 

Remove the parts of the Circle 
under the Tooth Profile 
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9. Extrude Profile   > OK 

10. Final Product  
11. Save 

 
 

Try other profiles:  
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SPANNER  or  
 

1. Draw a Rectangle & Dimension to 250 X 120. Draw a circle of Diameter 120 
at each end. 

2. Left Mouse Click (LMC) an edge of the Rectangle & Shift LMC a Circle. 
Both go red colour. 

          

Click  to ensure Tangency. Do the same to each edge & circle. 

3. Place Lines as below & Toggle Construction (Ctrl G) then Fix  

4. Remove unneeded parts of the Circles using  

  
5. Extrude the object Below Workplane > 12 > OK 
6. If the Palette is not turned on, goto Tools > Palette 
7. LMC & Drag the Hexagonal shape from Shapes tab of the Palette. Drop the 

centre point onto the centre point of the end curves. 

Files for this activity are at www.intad.asn.au 
follow to Pro/DESKTOP page 
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 Note: Each Hexagon is 
a closed Sketch & places a Sketch for itself on the respective Workplane. 

 
8. Dimension one of the Hexagonal circles to 40 & the other to 50. 
9. Extrude each Hexagon to Below Workplane > Subtract Material > 12 > OK 

 

10. Workplane > New Workplane >  > OK 
11. Right Mouse Click (RMC) > New Sketch > rename Project > OK 
12. Carefully choose the lines to Project.  
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13. Use Line > Project & these selected lines will be projected to the Project 

Sketch  
14. Carefully select the projected Construction Lines & return them to 

Construction Lines 
15. Add Circles (Diameter 120) to each end on Project Sketch 

  

16. Extrude  > OK 

Change Lines back to 
Construction Lines using 
Toggle Construction 

Add Circles 
120 Dia 

Use  Then LMC 
Constraints 

Inspector  
Remove tick  

 > OK 
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17.  Select ALL Hexagonal edges  using Shift LMC & use Chamfer tool       

 > OK 
18. Select ALL curves & Round to 3 

  > OK 
19. Select the long edges & Round to 3.  

20. Looks like this  SAVE 
21. Place into a New Album & use Chromium Plate, Dull 
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22. So now there is a Spanner. 
 

23. Load up that file & use File > Save Copy as > give it a different file name > 
OK 

 
24. Close the original file as the Assembly file is based on it & open the new file. 

 

25. Go to Features Browser   
 

26. LMC & Drag the Finish Flag to below Extrusion 1  Note that 

the Update Flag also moves up & the Update (green) Button  is ready to 
bring the Design to where you want it to be. This is a way of making file sizes 
smaller for moving larger files. Just open the file up at its new location & 
move the Finish Flag to the bottom of Features & LMC the Update Icon to 

regenerate the design.   
 

27. LMC the Spline Tool . Prehighlight the Line & move it in to form a curve 

  

The Spline Tool 
allows an edge to be 
dragged into a curve 
such as these edges. 

Notice ALL the 
other geometry of 
the design is still 
shown in place, but 
just not active at 
present 

Note: Moving the 
Finish Flag reduces 
the file size from 407K 
to 110 K 
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28.  Click the Update Icon  

 
 

29. LMC & Drag the Finish Flag to the bottom of the Features Browser 

  
 

30. LMC the Update Icon  & everything regenerates to the finished article. 

 
 

31. Save 
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32.   
 

33. Line > Add Text Outline > Size 8 > print 40 AF (8 spaces) 50 AF Use the 
Preview option to see if the Text is in the correct position > OK 

 
34. LMC & Drag Text to final position. Extrude > Above Workplane > Add 

Material > size 1 > OK  
 

35. This is the Top View 

 
 

36. Save 
 

37. Go to New Album. View > Zoom In to see letters at a reasonable size. Use the 

Select Faces  & LMC & Drag a suitable material over to each letter (just 

the top face of each one) then Update . View > 
Autoscale > Update  

 

38.  SAVE 

Select this Face & RMC choose New Sketch > OK 
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39.  
 

 
 
Notes: _______________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
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Reading Lamp  
 
This consists of three design files. Whilst the three parts, as described here, are not 

very detailed, other sections of these materials need to be adapted to ensure a correct 

outcome. 

 

Shade:  
 

1 Draw & Revolve Profile  
 
2 Select top & place hole (note the hole sizes so that the stem & base can contain 

matching sizes) in it using the Hole feature . 
 
3 Save. 
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Stem:  
 

1. Use Base Workplane for Path & Frontal Workplane for two Circles the correct 
size for Profile.  

2. Sweep Profile > along Sketch Path 
3. Save. 

 
 

Base:  
 
1 Use Tools > Palette > Shapes. Click & drag to drawing area. Note that the 
Palette items already have a Sketch included in them (have a look at the 
Workplane Browser for Sketch name) The Palette items will mate with the active 
Workplane. 
 
2 Extrude & (maybe) taper sides  
 

3 Place correct size hole  for Stem in base 
 
4 Save 

 

Assembly: 
 
1 Assemble the Base (fixed) & Stem using Align Centres & Mate the matching 
bottom of the holes. 
 
2 Repeat with the Stem & Shade. 
 
3 Save 
 
4 Open Assembly in the Album area & proceed to have fun. 
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Pool Freeform  or  
 

1. On the Base Workplane, using the Spline Tool  to draw the outline of the 

pool  
 

2. Save it as Pool. Use Save Copy as > Pool Insert 
 

3. Place a New Sketch onto the Base Workplane. Using the Spline or Rectangle 
Tool, draw an outline outside of the Pool outline & Extrude it to a suitable 

depth > Below Workplane > OK.  
 

4. Go to the Initial Sketch & Exrtude the Pool outline to a suitable depth > 

Subtract Material > Below Workplane > OK  

Files for this activity are at 
www.intad.asn.au follow to 
Pro/DESKTOP page 
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5. Select & use Round Edges to the round the base  
 

6. Save as Pool 
 

7. Open Pool Insert file & Extrude > Below Workplane > 2 > OK 
 

8. Save 
 
Assembly: 

1. New Design 

2. Assembly > Add Component > Pool > OK 

3. Assembly > Fix Component  

4. Assembly > Add > Component > Pool Insert > OK.  Note: That as the Pool 

outline was saved in both files from the original outline the Pool Insert fits 

neatly into the Pool hole.  

5. Select the Top Faces & RMC > Align 

6. Save as Pool Assembly. 

 
Album: 

1. New Album > OK 
 

2. Image > New Image > Pool Assembly > OK 

3. Use Faces  & Materials Browser to change material display on each face 

 
 
 

Pool Insert- Water 
 
Pool Walls- Marble Blue 
 
Base & Round- Concrete  
 
Top Surrounds- Checkerboard  
 
Outside Walls- Concrete 
 
Go back to Pool design file & Round the top 
Edge of the Pool- Marble Blue to contrast 
with the Pool Walls. 
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4. The Checkerboard colours are changed by double LMC on Face & 

 Set Texture to 0.2 > OK  
 

5. Update 
 

6. Save as Pool Album 
 

 
 
 
Notes:  
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MOULD  
 

1. Draw a rectangle & extrude it. 
2. Switch to the Plan View & construct the profile of the object. Curve the 

corners using the Arc/Fillet tool    
3. Switch to Isometric View & extrude to a suitable depth (refer to your 

requirements)  

4. Select the Draft Faces icon  & select Faces  

 > OK. The angle is to 

Files for this activity are at 
www.intad.asn.au follow to 
Pro/DESKTOP page 
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allow easy removal of the part from the mould after the forming operation is 
finished, so an angle of 10o is rather large but is used here so that the angle can 
be clearly seen. 

5. Select the edges & Round them to 5 mm radius as shown 

 
6. SAVE as Mould 
7. Start a New Design file 
8. Draw a rectangular block into which the original mould will fit 
9. Assembly > Add Component > select Mould > OK 

10. Use the Wire Frame to view both objects  

11. Use the Plan View & the Select Parts tool  to move the Mould Component 

into the middle of the Block  

12. Use the Front View & the Select Parts tool  to ensure that the Mould 
Component is level with the bottom of the Block 

 

13. View Isometric  

14. Feature > Use Component  



74 

For use with PTC’s Pro/DESKTOP 
Copyright remains with INTAD unless shown 

Free use by places of education 

15.  > OK 

16. Use the Enhanced icon  & Manipulate scene  to view the bottom face 

 
17. Select the bottom face & Right Mouse Click (RMC) 

 > OK 
18. Use View onto Workplane to view onto that face & draw a Rectangle so that it 

is symmetrical about the Mould Component.  
19. View Isometric & extrude that Rectangle > Below Workplane > Subtract 

Material > 5 > OK 
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20.   
21. Before use there are several other edges that would need Rounding. 
22. Further processing such as holes for the vacuum action to take place & 

pins/holes for a “cap” to fit over the mould. 
23. A male mould could be made so that a different method of manufacturing 

could be used. 
 

 

Using Revolve Profile to form half a Mould 
 

    

Draw & Extrude a Rectangular Block on 
Base Workplane 
 
New Sketch (Profile) 
 
Draw the Profile on Profile Sketch 

Use  to clean up the 
Profile 

View Isometric 
 
New Sketch (Revolve Line) 
 
Draw a Line as the revolving Line 
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 > OK 
 

 The Half Mould (Towball) 
 
Notes: 
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Album: 

1. Shown is a Thing  
2. The Album area allows Photo Realistic images to be coloured, duplicated, 

using the Image menu.  

3. New Image  
 
 

Note: 
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4. Image Properties  

  
 
 

5. Change items to see what effect they have in the Album. 
 
 
Notes: 

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________ 

Image Resolution 

Change 
Foreground 

Change 
Background 

Change 
Lighting

Change 
Camera 
Lens 
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Coffee Time Album:  
 

1. This is one of the sample drawing provided with Pro/DESKTOP and is used in 
the Tutorials in the Help menus.                                                               
Usually C:\Program Files\PTC\Prodesktop2000i\Samples 

 
2. File  > New > Album > OK 

3. Image > New Image > choose Coffee Time > OK > Update  

4. Goto >   

5. non-metal > + > - >  > LMC & drag the Mirror Bag to the Part 
until the correct Wire Frame appears > then let the mouse key go  

 
6. Change the Base to Mirror & the Tile to Glass > Update  

 
 

7. Note the Shadows  
 
 

8. Change the Lighting &/or the Camera in Image > Image Properties & see what 
other different Shadows that can be produced. 

Change 
to Mirror 

Change to 
Glass 
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9. Floodlights  
 
 

10. Enjoy 
 
 
 
Notes: _______________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
 
_____________________________________________________________________ 
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Crane Hook Album:    
 

1. File > New > Album > OK 

2. Image > New Image >  > OK 

3. Update  

4. Goto >   

5. non-metal > + > - >  > LMC & drag the Glass Bag to the Part 
until the correct Wire Frame appears > then let the mouse key go  

Much of this detail 
is hidden in a 
normal view. 
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       > Update  
 

6.    
 
7. Notice what Image > Image Properties > Studio > Lighting > Floodlights 

 > OK does to Crane Hook  
8. Save as Crane Hook Album 

 

Detail can be 
clearly seen 
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Logo Decal   
 

1. Select a Face    

2. Selected Face goes reddish  

3. Image > Apply Decal becomes available   

4. Choose the Logo & Transparency Bitmaps  
> OK (In this case, both Bitmaps were the same) 

5. A box appears. By carefully moving, rotation & sizing the Decal box can be 

positioned to give the required view.  The Blue 
circle will allow rotation & positioning. The sizing icon is the same one as for 
positioning instead of the normal MS Windows double headed arrow. 

- Finish the Material choice & Update 
before Select Faces 
 
- This Decal Bitmap is an EXPORTED  
bitmap Pro/DESKTOP Design. Other 
programs could allow more artist freedom in 
the design & saving options. 
 

Files for this activity are at 
www.intad.asn.au follow to 
Pro/DESKTOP page 
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Sometimes there will be a need to use the (keyboard) arrow keys to identify 
where the Decal box has placed itself. 

6. Rotated, positioned & resized   

7. Use Update to finish  

8.  
9. The Decal can be put on a variety of surfaces  

10.   
 
 
 
Extension:  

1. Design your own Logo on paper.  
2. Use Pro/DESKTOP or another program to do an electronic copy of it.  
3. Save it as a .bmp (bitmap) file to the folder:  
      C:\Program Files\PTC\ProDESKTOP 2000i2\Program\Bitmaps 
4. Pro/DESKTOP does not give an option of looking into any other folder. 
5. The other program may allow the saving of a Mask & a Demask file.  
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Single Point Perspective Room (sort of): 
 

1. Use Base Workplane & View onto Workplane  
2. Draw a design file as shown 

 
3.  

 
 
 
 

4. Remove unneeded Lines  
5. Gives this 

 

Start with large Rectangle 
 
Draw Lines for Diagonals 
 
Draw back Rectangle 

Draw front of Cupboard 
 
Draw Lines to Centre of 
Vision 
 
Draw back of Cupboard 
 

Draw Bed & Set of Drawers 
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6. Start a New Drawing  

 
 

6. Sort of Perspective & a bit of fun. 
 
 
Notes:  
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Solid Geometry / Intersecting Solids 
 
Cylinder to Cylinder 
 

1. Draw a cylinder @ 0,0  on Base Workplane 

 
2. Put New Sketch on Frontal Workplane > Cylinder Horz > OK 
3. Draw Circle on center line of Cylinder & extrude. View Wire Frame 
 

 
4. Move Horizontal Cylinder to show Line of Intersection of offset centers. 
 

 
 

Shows Line of Intersection 

Front 
 
Back 
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Right Cylinder to Right Cone 
 
1. Reuse the original Cylinder & turn it into a Cone. 

 
2. Update & Wire Frame shows students Line of Intersection between Cone & 
Cylinder 
 

 
 
 

  
 
 
 

Drag Green Button inwards for 
Cone to form. 

Offset the Cylinder & Update 
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Transition Pieces 
 
1. Use Features > Loft through Profiles to show Transition Pieces when developing 
using Triangulation. 
 

 Square to Round 
 
 

2.  Round to Rectangular 
 
 

3.  Pentagon to Round 
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About Creating and Modifying Templates 
 

You can create new templates by modifying the templates already provided. 

1. Create a bitmap to display on the button. The bitmap should be no larger than 84 pixels wide 
by 60 pixels high.  

2. Save the bitmap with the BMP extension, in the application subfolder \Program 
\Drawing Formats.  

3. Determine which of the six current templates most nearly matches the layout you want. You 
are going to backup and modify that file.  

4. Click File> Open> Drawing and open the template file.  
5. Click File> Save Copy As and use a name for future reference to indicate it is the backup of 

the original you are modifying.  
6. Edit the source template as desired, then save and close the file. In a template, you can create 

the same visual elements as a format, in fact, templates can use format files, which will be 
automatically used by each drawing created. To have an existing format used automatically, 
use it as the format for the template. To include view layouts sketch rectangles and label them 
with the orientation. The properties of each view can be defined by typing Visual Basic 
commands as notes inside the rectangles and labels. Examples and hints are included in the 
templates to help you.  

7. Using a text editor, navigate to the application subfolder \Program\Drawing Formats, 
and open the file Templates.lst.  

8. The file is organized as four-line blocks of listings, each corresponding a template file. Locate 
the block for the file you are modifying. Overwrite the existing data as follows.  

1. Do not modify the first line, the name of the template file. It is used to link to the 
selection button.  

2. On the second line, type the name of the bitmap file that you want to appear on the 
selection button.  

3. On the third line, type the description that you want to appear in the dialog box when 
the cursor pauses over the selection button. Enclose the text in double quotation 
marks.  

4. On the fourth line, type one of the following: 
NoDesign (to open an empty drawing with no views) 
NewDesign (to open an empty drawing with empty views) 
SelectDesign (to prompt the user to select a saved design, currently open in a 
window, to display in the drawing).  

9. Save and close the file.  

Notes 

If you are using Windows 2000, you must have administrator privileges to modify or create a 

file in a folder used by an application, including template files. 
 
 

To create a new template, perform the following steps: 

From Pro/DESKTOP Help File 
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92 

For use with PTC’s Pro/DESKTOP 
Copyright remains with INTAD unless shown 

Free use by places of education 

 
 

 
A Pro/DESKTOP sample file shown 
as an Open-In-Line Pictorial 
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A Pro/DESKTOP sample 
file shown as an Open-In-
Line Pictorial with partial 
sectioning 
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Graphics 2000 Book 2- A. Boundy/I. Hass 
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Notes/Sketching Page:  
 

 

 

 

 

 

 

 

 

 

 

 


